Collector: Multiple layers are referencing a dataset, which is not supported

4646
4
Jump to solution
06-18-2015 09:37 PM
PeterTimmers
Occasional Contributor III

Can't seem to go offline with a new feature service and I'm getting the following error:

The operation couldn’t be completed. Failed to create a replica. Multiple layers are referencing a dataset, which is not supported.

I can't look at the log files for this arcgis server so I'm having more trouble than usual.

  • 10.3 ArcGIS Server
  • 2012 SQL Server SDE
  • Copied feature classes (point, line and polygon) which have worked previously - no joins or references or attachments
  • Archiving enabled
  • Editor tracking enabled
  • Published to new AGOL for org - connected to feature service root.
  • Details for webmap are showing that Offline is Enabled.

Can anyone see whether I'm missing something?   I thought I had ticked all the boxes. 

I didn't establish the SQL Server and I don't have a lot of control over the ArcGIS Server 10.3. I'm a little worried it's something in one of those.

0 Kudos
1 Solution

Accepted Solutions
PeterTimmers
Occasional Contributor III

I think Russ answered my problem earlier

Offline multiple layers

Two of the layers are the same featureclass. Shame the error message is not a little more informative.   It's like we need a tool within ArcGIS Desktop or AGOL that can test a feature service for offline capability.

View solution in original post

4 Replies
MiaogengZhang
Esri Regular Contributor

Are you testing with latest Collector, 10.3.1?

0 Kudos
PeterTimmers
Occasional Contributor III

Yes on iOS.  To me it must be a SDE or SQL Server setting or version.  Could it be the editing rights on the featureclass?

I'm going to have to put a local support request in.

0 Kudos
PeterTimmers
Occasional Contributor III

I think Russ answered my problem earlier

Offline multiple layers

Two of the layers are the same featureclass. Shame the error message is not a little more informative.   It's like we need a tool within ArcGIS Desktop or AGOL that can test a feature service for offline capability.

NiekGoorman1
New Contributor III

If it's any consolation, that error message used to just say "failed to create replica" with no further information at all.

0 Kudos