Collector Crashing on Photo Capture in iOS7

6523
27
10-28-2013 12:37 PM
DominickCisson
Occasional Contributor
Trying out collector with a rather simple sign collection setup, and it seems to crash inconsistently on iOS7 when trying to capture a photo for an attachment.  Images captured using the front-facing (low resolution) camera on an iPhone or iPad seem to work fine.  Those captured using the rear, higher resolution camera often crash Collector.  The crash occurs specifically after taking the photo, and then clicking "Use Photo" to attach the photo to the point.  About 60-70% of the time, attaching a high-res photo simply kills Collector.  Has anyone else experienced this?
Tags (2)
27 Replies
RussellRoberts1
Esri Frequent Contributor
Which versions of the iPhone and iPad are you using and are you using iOS 7 are you using 7, 7.02,7.03 . I can't repro this with iPhone 5 running iOS 7.03. We do have an update coming out very soon with iOS 7 support. Hopefully the issue will not be reproducible with the update.

Russ
0 Kudos
DominickCisson
Occasional Contributor
As seems to be typical, when I post an issue to an ESRI forum or log a bug report, it magically goes away.  Granted, we did upgrade our back-end ArcGIS Server from 10.1 to 10.2 as well, so perhaps that did the trick.  Needless to say, for now the Collector crashing in iOS is gone, at least for now.  I like many others I'm sure am very interested in the upcoming Collector update.  Is there a more concrete release date for it now?  Earlier ESRI blogs had it pegged at late September.
0 Kudos
RussellRoberts1
Esri Frequent Contributor
The app has been submitted to the App Store and is currently going through Apples approval process.

Cheers
Russ
0 Kudos
DominickCisson
Occasional Contributor
Awesome... I'll be looking for it.  My last response was a bit premature, as we're still seeing a few crashes here and there.  FWIW, the test platform is iOS 7.0.3 on an iPhone 4s and an iPad 3.  I won't waste any more time chasing this down though with the new version imminent.  Thanks.
0 Kudos
NadineHughes
New Contributor
After reading this thread, I realized I have just downloaded the new update of the collector app (10.2 - Updated Nov 4th 2013), and I am still experiencing the same problem with iOS 7.0.4 for Iphone 4s and attaching pictures to features. The app allows me to collect a picture, but when I tap "Use Photo" the whole app crashes.
0 Kudos
RussellRoberts1
Esri Frequent Contributor
Can you share the map and service that is reproducing this issue? I tried it on my 4S and 5 and cannot repro it.

Thanks
Russ
0 Kudos
SheldonBaumgartner
New Contributor
I'm having the same issue on the Android side.  We are looking at using the app for data collection using multiple platforms, but when I use my phone (Android 4.1.2 and the newest Collector version 10.2) the app crashes when I try to attach a picture I'm taking from the camera.  Tried uninstalling and re-installing the app, but no luck.  I can add points without an attachment or add a picture from my gallery that I have already taken and it works just fine.  It's just when I try to add a picture directly from the camera, it doesn't work.
0 Kudos
RussellRoberts1
Esri Frequent Contributor
Are you using a samsung device? We have a known issue with the camera app crashing on samsung devices but has been fixed with their 4.3 update. If you try using another camera app like Camera MX instead of the stock camera app try and see if this solves the issue for you.

Thanks
Russ
0 Kudos
SheldonBaumgartner
New Contributor
Thanks Russ, that solved my problem!
0 Kudos