Cannot take Collector App Offline

3972
11
Jump to solution
07-28-2015 12:37 PM
JamisonPeevyhouse
New Contributor III

I am new to my post, so still learning how to do the ArcOnline. My predecessor  created the database and server connections and made a collector app. It works. However when I am trying to make one making sure to include GlobalID and enable archiving and allowing attachments as described in the tutorials available. Also through the publisher allowing sync and editing capabilities. When I add the file to a basemap created by my predecessor, you can see all of it on the application. However you cannot enable offline when you try to edit the actual map. It allows you to create the point until you try to save/sync it. Is there a step that I somehow missed? Any advice will be greatly appreciated.

0 Kudos
1 Solution

Accepted Solutions
RandyBurton
MVP Regular Contributor

Looking at your feature layer properties (via My Content), does it indicate sync is enabled? If not, can you edit the property and check enable sync?

View solution in original post

0 Kudos
11 Replies
RandyBurton
MVP Regular Contributor

First, check the properties of your layer.  "Sync" should be enabled.  Sounds like you have done this.

Also check the properties of your map.  There is a property called "Offline Mode" which also needs to be enabled.

0 Kudos
JamisonPeevyhouse
New Contributor III

The properties that you are talking about. Would that be from the "My Content" page in which you select the map and then edit. At the bottom it has 3 check boxes "Prevent this item from being accidentally deleted", "Allow others to save a copy of this item", and "Enable offline mode"? When I try to 'check' the offline mode it sends me a popup "This web map cannot be enabled for offline use. Learn more about taking your maps offline." However I have done everything it states so I am not sure where I have messed up.

0 Kudos
RandyBurton
MVP Regular Contributor

What about the properties of your feature layer?  Under My Content, you should see a link with the feature's name that will take you to the service URL (REST API).  On the next page near the top, you should find a link for JSON.  Near the bottom of the JSON you should see a line like this: "capabilities" : "Create,Delete,Query,Update,Editing,Sync".  It should include "sync".

Also, could you briefly describe how you create the feature layer? Do you start in ArcMap and publish it from there?

0 Kudos
JamisonPeevyhouse
New Contributor III

"Create,Delete,Query,Update,Uploads,Editing" Is next to the capabilities. I created the feature class through Catalog, created my fields, domains ect. Enabled archiving and Global IDs. Imported that into an ArcMap file to do the symbology saved it then went through the normal Map Service process. Turning on access to "Feature Access" to include Sync, create, edit delete. Then using an existing base map in "My Content" added the feature layer to it and saved it.

When I try to add data in ArcMap, ArcViewer, or through a Mobile device it will not allow me to. I can see the fields I just cant seem to edit them. So maybe it is a permission issue with my database? But I am not sure how to change it.

0 Kudos
RandyBurton
MVP Regular Contributor

Looking at your feature layer properties (via My Content), does it indicate sync is enabled? If not, can you edit the property and check enable sync?

View solution in original post

0 Kudos
JamisonPeevyhouse
New Contributor III

Well even though I have changed this particular file's permissions several times within the database. This time it has worked. So it seems to be just a permission issue that did not want to resolve itself. It is fixed. Thank you so much for your time and effort to help me figure out this problem.

0 Kudos
ElainaO_Rourke
New Contributor II

I am having the exact same issue and it sounds like I have gone through the same process that you have. Can you explain more about what permissions you had to change in order to fix this? My JSON also doesn't say that "Sync" is a capability, but I thought I had enabled it in all of the options. Thanks!

0 Kudos
ElainaO_Rourke
New Contributor II

My JSON says "capabilities": "Data,Map,Query", even though I have enabled sync in the Feature Access operations. How else can I enable sync so that I can enable offline mode??

0 Kudos
RandyBurton
MVP Regular Contributor

When publishing a service from ArcMap, go to "Capabilities" and enable "Feature Access" and then select the following under "Operations allowed": Create, Delete, Query, Sync, Update.  Your feature should be published
with the correct settings.

If the layer has been published, go to "My Content:" and select the layer (view item details). At the top of the screen will be a series of options that include open, share, edit, etc. Select "edit".  Near the bottom is a section for Properties.  Check the selections to enable editing and to enable sync and save your changes.

It is also possible to edit the json file and update the section "capabilities" to "Create,Delete,Query,Update,Editing,Sync".  I suggest this only if you cannot republish the layer with the sync setting enabled, only after backing up your data and if you are comfortable using the REST API.  To edit the json, you will need to insert "admin" in the url: .../arcgis/rest/services/... becomes .../arcgis/rest/admin/services/...  (assuming you are using ArcGIS Online).  You will need sufficient privileges to do this action. A link "Update Definition" will be available at the bottom of the page.

0 Kudos