How to align imported objects to terrain?

970
3
Jump to solution
05-20-2019 04:23 AM
JafarNajafli
New Contributor III

I have a set of objects (.obj) that I prepare in Sketchup and import it into Cityengine. 

What I'm trying to do is to align those objects (which Cityengine sees as 1 object) into my terrain in CE but it doesn't work. The reason I think is that they're not models/shapes created in CE. 

Is there any workaround to align them to terrain? Or is there any other format that'll enable CE to recognize my objects separately and align them?

Screenshot attached.

Chris Wilkins Devin Lavigne

0 Kudos
1 Solution

Accepted Solutions
ThomasFuchs
Esri Regular Contributor

Hello Jafar

Thank you for your question.

Please make sure that each obj file you obtained from Sketchup is imported as a separate Static Model into CityEngine. Please refer the CityEngine help Static models—Help | ArcGIS , then select the Static Models with the Align shapes to terrain—Help | ArcGIS tool.

Note: if the Align Shapes to Terrain is disabled make sure a regular Shape or Model is in the selection.

View solution in original post

3 Replies
ChristianIten
Esri Contributor

Hi 

CE has no dedicated functionality to split up your imported obj into separate buildings. still:

- you might try to convert the imported model into shapes, select those belonging to one building and combine it.

- you can export an obj per building and then import all of them in CE.

- you can export the terrain from CE, import it into SketchUp and do the alignment there.

A typical use case for obj import would be importing one (hero) building into CityEngine. CityEngine (i.e. CGA) is perfect to create the mass models that you are showing in the screen shot. 

Additionally also from our side: Thanks for your feedback. The forum is very important to us, and we put more resources to it.

Have a nice weekend

Christian

JafarNajafli
New Contributor III

thank you too Christian, we believe in CE!:)

0 Kudos
ThomasFuchs
Esri Regular Contributor

Hello Jafar

Thank you for your question.

Please make sure that each obj file you obtained from Sketchup is imported as a separate Static Model into CityEngine. Please refer the CityEngine help Static models—Help | ArcGIS , then select the Static Models with the Align shapes to terrain—Help | ArcGIS tool.

Note: if the Align Shapes to Terrain is disabled make sure a regular Shape or Model is in the selection.