Exporting CityEngine model to Unity

734
2
09-23-2021 11:26 AM
AnnaConway
New Contributor

Hello! I've been running into an issue where exporting my models renders them invisible in Unity. I have also tried to import the .fbx generated by CityEngine into Maya and it is invisible there too.

Not quite sure what is going wrong.

I'm using the "Building_From_Footprint.cga" for buildings that I have drawn shapes for and the "Complete_Street.cga" for the roads I have drawn as well. The buildings generated by the engine have a default rule applied when I got the map data. 

I have followed the Esri page on how to export as well as this video with no luck. My scale in Unity is not the issue.

In Unity, I am receiving errors such as:

Next vertex not found in CheckWinding()
UnityEngine.GUIUtility:ProcessEvent (int,intptr,bool&)

And warnings such as:

Mesh 'CityEngineMaterial_6_m' has no normals. Recalculating normals.

A polygon of Mesh 'CityEngineMaterial_m' in Assets/DigiRoc/Roads/DigiRoc_0.fbx is self-intersecting and has been discarded.

ImportFBX Warnings:
Can't import normals, because mesh 'CityEngineMaterial_10_m' doesn't have any.
Can't import normals, because mesh 'CityEngineMaterial_11_m' doesn't have any.
Can't import normals, because mesh 'CityEngineMaterial_1_m' doesn't have any.
Can't import normals, because mesh 'CityEngineMaterial_2_m' doesn't have any.
Can't import normals, because mesh 'CityEngineMaterial_3_m' doesn't have any.
Can't import normals, because mesh 'CityEngineMaterial_4_m' doesn't have any.
Can't import normals, because mesh 'CityEngineMaterial_5_m' doesn't have any.
Can't import normals, because mesh 'CityEngineMaterial_6_m' doesn't have any.
Can't import normals, because mesh 'CityEngineMaterial_7_m' doesn't have any.
Can't import normals, because mesh 'CityEngineMaterial_8_m' doesn't have any.
Can't import normals, because mesh 'CityEngineMaterial_9_m' doesn't have any.
Can't import normals, because mesh 'CityEngineMaterial_m' doesn't have any.
Can't import normals, because mesh 'CityEngineShapeMaterial_m' doesn't have any.

UnityEngine.GUIUtility:ProcessEvent (int,intptr,bool&)

Here is a screenshot of my project if it helps. There aren't many textures other than the sidewalks. Some of the more detailed models like that chapel were imported into CityeEngine by a 3D Modeler who hand-made them in Maya. Thank you!

AnnaConway_0-1632421432113.png

 

 

2 Replies
AnnaConway
New Contributor

Also, aside from bumping, if anyone could point me in the direction of another resource that may help (another forum, community, etc) that'd be equally appreciated 🙂

0 Kudos
by Anonymous User
Not applicable

I don't know if I can be much help on a technical question like this, but have you tried the cleanupGeometry rule when you import your "hand-made" Maya fbx models into your CityEngine scene/rule files?   That might help resolve some of the issues.

0 Kudos