Embedded videos not carrying over

154
5
10-07-2020 09:45 AM
RyanGay2
New Contributor III

I have videos embedded into my web map on AGOL. I am trying to create a native app using the Map Viewer Template 4.3 and as you can see the embedded video shows up just fine in the webmap, but when viewed from the native app all you can see is the embedded code. Is this not supported?

5 Replies
ErwinSoekianto
Esri Regular Contributor

Ryan, 

I am trying to create a repro case for this, how do you embed videos in the popup? I have the sample webmap with embed video here, https://www.arcgis.com/home/item.html?id=0dd52c7027894c4eb2c30b184191fd59, but I want to understand how it is created. 

It is most likely a bug with this PopupManager QML Type | ArcGIS for Developers, this is what we are using to display pop-up in MapViever. 

Erwin. 

RyanGay2
New Contributor III

Erwin thank you. The embedded code you see in the screenshot from the mobile device is a field in the attribute table of the data. Each point is attributed with its own video, and then the pop-up is configured in the web map.

0 Kudos
ErwinSoekianto
Esri Regular Contributor

Ryan, 

I will take it back, this is not an issue with ArcGIS Runtime SDK for Qt PopupManager QML Type | ArcGIS for Developers, this should be an enhancement to the AppStudio MapViewer template. 

If you can help us submit this as an official enhancement to support embed video in the popup for MapViewer template via Esri Technical Support‌, that would be amazing. 

Erwin. 

RyanGay
New Contributor

Erwin I would be happy to help with that. Are there certain channels for submitting official enhancements?

0 Kudos
ErwinSoekianto
Esri Regular Contributor

I think contacting Esri Technical Support‌ can be done through email or phone call. Esri Support Contact Support 

0 Kudos