AppStudio Beta 3 Issues

2774
2
08-03-2015 09:47 AM
TracyGarrison
New Contributor III

I have made a list of some observations associated with the Beta 3 version of AppStudio Destop and the AppStudio Player on iOS and they are as follows (some of these have been mentioned before but I am mentioning them again because I get different results based on what computer I am using):

 

AppStudio Desktop Notes Beta 3

Settings / Quick Properties page does not scroll correctly if at all:

Office workstation--- (two monitors)

   Solution:  I have found that draging the Settings window to my second monitor  usually fixes the problem.  Sometimes I have to close the setting page open it again and drag it over again to get this to work.  Eventually it does.  There are other threads here mentioning this problem so it is not an isolated incident.  My display driver is: ATI Radeon HD 3400 Series version 8.970.100.7000 Resolution of monitors set at 1280 x 960

Home Computer--- (One Montitor) 1920 x 1080 resolution (AMD Radeon R7 200 Series).

  I never have a problem with the setting / properties window not scrolling on this pc.  I have a hunch it has to do with resolution and scroll bar interface calculations.   Perhaps others can post replies as to whether they are or are not having this problem (either way report number of monitors and resolution and perhaps video card info).

 

Quick Reports:

Downloading App to the iPhone or iPad using the Player App:

  The iOS player displays downloading and runs up to 100% but then it stops and message does not go away.  I close the player app and open it again to solve the problem.  The downloaded Appstudio app will then be there and will run.  Notes: iPhone 5 64 GB with iOS version 8.4, iPad

(v3) 64 GB with iOS version 8.4

Downloading App to AppStudio Desktop:

I only have a 64 bit version of this application on my Office workstation and on my Home PC but I have the same problem as I have on the iOS AppStudio Player.  The downloading runs up to 100% and then freezes.  Have to close the AppStudio application and start it again.  The app that was downloaded will then work as it was downloaded 100%. See image uploaded

Thumbnail image:

Thumbnail does not show up in the desktop app or the player app (in iOS) I don't know about Android.

When you log in to your orginazation account and the app has not been loaded on the device yet you will see the thumbnail image.  After you download the app the application Title will be displayed but with a blank thumbnail.  (See attached images).

Maximize Window:

Office Workstation --- Maximize and return to normal window works fine on Office workstation

Home Computer ---

Maximize the AppStudio Window.  If you maximize the AppStudio Desktop window you will not be able to choose between the different apps.  But if you double click the app that is already selected as if to "Play it" in Player it will play and then you can go back and forth between the

different apps you have.  If you return the the reduced window size you will still be able to move between the apps until you maximize again

then it will not until you double click the one selected to start it. 

Here you can see blank thumbnail in the Desktop Application and you can see the Download info stuck at 100%.  This only happens to when using the Quick Reports.

AppStudioDesktop2.jpg

Blank thumbnails in IoS  (the download freezes in iOS Player as well).

iOSPlayer.jpg

Tags (1)
0 Kudos
2 Replies
TracyGarrison
New Contributor III

Just to be clear.  The downloading problem and the blank thumbnails only happen when I use the quick report template.  I have actually loaded thumbnails of the correct size.  But they never show up.

0 Kudos
MarikaVertzonis
Esri Regular Contributor

Thank you Tracy for your detailed feedback. Below is some confirmation and responses that I hope will be helpful for you to continue working with AppStudio:

Settings / Quick Properties page does not scroll correctly if at all:

Yes we have been working to figure out exactly whats going on here. We have observed a strong correlation between being signed in and not. If you do not sign in to AppStudio and launch the Settings tool you can edit the properties comfortably. If you sign in (or are already signed in to the main gallery page before you click the Settings tool, you will find that until the sign is complete you will have a small window of opportunity to edit the properties, but then everything freezes once sign is complete. Our hope is that this will be fixed in Beta 4.

Quick Reports:

We have had a few inquires about quick reports behaving different on iOS than other platforms. this is not expected and we are still looking to find a reason for this.

Downloading apps and thumbnails:

We have also observed the downloading app freezing at 100% - but it has been intermittent. Thumbnail appearing blank is known - do click the refresh button to display the thumbnail after download. We've seen it with apps built from templates and also new apps.

Maximize Window:

This one intrigues me. I can not reproduce this. can you give a little more detail on this one? When i maximized the screen i could still click on different apps and launch them either by double clicking or by clicking the player button - is that what you are attempting?

0 Kudos