Error: Failed to create environment - Clone and active new environment in ArcGIS Pro 2.4 to add Tensorflow package

09-09-2019 10:42 AM
New Contributor

Hi..I tried to add Tensorflow Package in ArcGIS Pro by cloning existing arcgispro-py3 environment to run deep learning package in ArcPro. Unfortunately, it gives an error "Error: Failed to create environment" and I cannot add TF package. I am using Pro 2.4 with professional license. I am currently learning ArcGIS Pro for Deep Learning using ESRI training module ""... Appreciate any helps and support to resolve my issue.. 

5 Replies
New Contributor

If you hover over the red exclamation mark you should get some more information on the error. Could you try that and share a screenshot of the more detailed error?

I was having the same issue and it turns out my companies firewall was blocking the request the application was making.

0 Kudos
New Contributor

I had the same error and shows the same message on the red exclamation mark. How did you fix that @Sean Wellman?

0 Kudos
New Contributor

Try running pro as an administrator. I had this problem and I was able to clone using this method.

New Contributor II

As per Nathan's suggestion, I also found that running as Administrator resolved this problem. Further, for those who might be interested, I've put together a little tutorial on GitHub that shows how you can use Anaconda to manage packages within cloned ArcGIS Pro Python environments.

0 Kudos
by Anonymous User
Not applicable

This was helpful.  Running as admin solved my issue.  Thanks a bunch.

0 Kudos