Select to view content in your preferred language

Can't upgrade API to 1.4 - Conflict with Anaconda

2660
13
Jump to solution
03-30-2018 10:55 AM
PhilLarkin1
Regular Contributor

I'm encountering an odd error when following the instructions for upgrading the package for Pro (2.1.2) located here: Install and set up | ArcGIS for Developers. I'm upgrading the Python API from 1.2.5


Using the Python Command Prompt packaged with the Pro installation leads to the error (see attachment): 'Package not found: 'arcgis' Package 'arcgis' is not installed in F:\Anaconda3\envs\arcgispro-py3 

There appears to be a conflict between my Anaconda installation and the conda installation packaged with ArcGIS Pro. It is odd that the Python Cmd Prompt doesn't recognize a package in the Pro environment because it is active. I tried adding a system and user path variable: "C:\Program Files\ArcGIS\Pro\bin\Python\Scripts". That didn't help. 

Has anyone experienced this and have any ideas? 

David Wynne

Joshua Bixby

0 Kudos
13 Replies
PhilLarkin1
Regular Contributor

Thanks again for taking a look at this.

What is odd is that I don't have an Anaconda environment for arcgispro-py3 at Anaconda\envs. I removed my F:\Anaconda\.. references from the PATH system variable. I received the same error when trying to upgrade my arcgis package ("Package not found: 'arcgis' Package 'arcgis' is not installed in F:\Anaconda3\envs\arcgispro-py3").

I uninstalled Anaconda and received this error when attempting to upgrade: 'The system cannon find the path specified.'



I can still use python in Pro, so it is still recognized. I think there is an issue with the activate.bat file. I'm going to uninstall/reinstall Pro and cross my fingers. It won't be fun doing this in a production environment but hopefully it fixes the issue. 

0 Kudos
PhilLarkin1
Regular Contributor

After uninstalling Anaconda I fully uninstalled Pro (deleting C:\Program Files\ArcGIS\Pro after uninstall). Installed Pro 2.1. Upgraded to 2.1.2.

I then successfully ran the upgrade conda upgrade command. Uninstalling everything was the solution. 

There were traceback errors on the conda upgrade. see attachment to the original post.

0 Kudos
ShaunWalbridge
Esri Regular Contributor

Great, glad you found a solution that worked. The Python API team is aware of the traceback issue, unfortunately its caused by the uninstall of the old version (1.2.5) and they can't retroactively patch that, but will be able to insure it doesn't appear on future upgrades.

JaredSellers1
New Contributor II

The Install Offline works- Install and set up | ArcGIS for Developers 

0 Kudos