Best approach for a workflow API Python & arcpy?

06-12-2019 02:28 PM
Occasional Contributor

I'm trying to update our sde with a hosted feature layer. 

What is the best approach for this. I'm aware of the API Python and Arcpy.  I'm a little confused on how to start of this script. I have a fair amount of knowledge with arcpy and have created complex scripts with it. 

The goal is that this script will run automatically or when ever I want it to. Basically I want to take a hosted feature layer that is a copy of our database and update changes that were captured in the Hosted Feature Layer back to our database. 

Do I use the API for Python to connect to the Hosted feature layer or can I use Arcpy for that? Would I use both the arcgis python API and arcpy ?

Any guidance would be appreciated! 



0 Kudos
13 Replies
Occasional Contributor

Its weird because if I type in OBJECTID < 287 it will download. But if i put anything higher than OBJECTID < 287 for example OBJECTID < 288 it will give me that load table error. 

I thought this had something to do with the max record counts but when I look at the data it says 1000. 

0 Kudos
Esri Esteemed Contributor

Adam Arcichowski‌ I think something may be corrupt with this service.  If you filter the service by OBJECTID = 287, there are 2 features:

Not sure how that is occurring since you cannot have duplicate OBJECTIDs.

0 Kudos
Occasional Contributor

Hmm weird. 

They turned off their service anyways. 

0 Kudos
Occasional Contributor III

Hi All 

I ran into the same error this morning and my feature would not download

"fs.load(fsURL)": RecordSetObject: Cannot load a table into a FeatureSet

Not sure if this has anything to do with it but the highest Object id was 4002 and the script was showing the message 

Copying features with ObjectIDs from 2034 to 3034
Copying features with ObjectIDs from 3034 to 4034 

Then it failed 

So i used the where clause  and  specified the Object id to be less then or equal to the Highest object id in the table at the time and it worked as expected.  I then appended some information to the table and ran it with out the query and it seems to be working fine again. 

0 Kudos