ArcGIS API for Python Kernel crashing when I visualize an SEDF containing polygons

343
1
10-16-2020 01:24 PM
MonicaHersher1
New Contributor

The issue

I have a spatially enabled dataframe (SEDF) that contains Ring geometries in the SHAPE column and am trying to plot it using the spatial.plot() method of SEDFs. I can get it to work with point geometries, but when I try to plot a polygon the kernel of my notebook crashes every time. Wondering if it was my dataset, I went back to the notebook in the documentation to see if the same thing happens when I run the Polygon example listed there. I've found that it does the same thing (ie. the kernel dies when I try to run the example that plots a ring geometry, but not when it plots the point geometry).

Replicating

I'm using arcgis version 1.8.2 installed on MacOS Mojave Version 10.14.6. I've tried running the notebook connected to ArcGIS Online as an anonymous user and with my credentials. The issue is the same both ways. You can recreate the issue I'm having by running the  code that comes from the polygon example in the ArcGIS Python documentation. I've included a notebook that is a copy of this documentation (visualizing data with the spatially enabled dataframe | ArcGIS for Developers), but pared down to only include the point example that works fine and the polygon example that errors. You should be able to replicate the issue by running this notebook with the arcgis python API version 1.8.2.

0 Kudos
1 Reply
DanPatterson
MVP Esteemed Contributor

made it through to step 8 without issue. 

Everything installed in the base environment, not a clone.

I keep all package updated.

(arcgispro-py3) C:\arc_pro\bin\Python\envs\arcgispro-py3>conda list arcgis
# packages in environment at C:\arc_pro\bin\Python\envs\arcgispro-py3:
#
arcgis                    1.8.2                 py36_1275    esri
arcgispro                 2.6                           0    esri

(arcgispro-py3) C:\arc_pro\bin\Python\envs\arcgispro-py3>conda list jupyter
# packages in environment at C:\arc_pro\bin\Python\envs\arcgispro-py3:
#
jupyter_client            6.1.2                    py36_0    esri
jupyter_console           6.1.0                    py36_0    esri
jupyter_contrib_core      0.3.3                    py36_3    esri
jupyter_core              4.6.3                    py36_2    esri
jupyter_nbextensions_configurator 0.4.1                    py36_1    esri
jupyterlab                2.0.1                    py36_0    esri
jupyterlab_server         1.2.0                      py_0

(arcgispro-py3) C:\arc_pro\bin\Python\envs\arcgispro-py3>conda list notebook
# packages in environment at C:\arc_pro\bin\Python\envs\arcgispro-py3:
#
notebook                  6.1.4                    py36_1    esri
pro_notebook_integration  2.6                      py36_5    esri
spyder-notebook           0.3.0                      py_0    spyder-ide

(arcgispro-py3) C:\arc_pro\bin\Python\envs\arcgispro-py3>conda list pandas
# packages in environment at C:\arc_pro\bin\Python\envs\arcgispro-py3:
#
pandas                    1.1.2            py36ha925a31_0

(arcgispro-py3) C:\arc_pro\bin\Python\envs\arcgispro-py3>

... sort of retired...
0 Kudos