AnsweredAssumed Answered

AttributeError: 'GIS' object has no attribute 'admin' :/

Question asked by rmurra28_GISandData on Dec 14, 2018
Latest reply on Dec 17, 2018 by rmurra28_GISandData



I'm playing around with the ArcGIS API for Python and have hit a snag. My issue is the same that is mentioned in this 

previous thread, but unfortunately I've tried the recommendations listed in there and have been unable to resolve the issue. Some notes:


  • My organization uses ArcGIS Online with OAuth 2.0
    • I was able to use the instructions here to successfully log in 
  • I created a new environment and updated the arcgis package to 1.5.2
  • In ArcGO, my user type is Creator, and my role is Admin
  • I made sure to update both ArcGIS Pro and the Python API after the December update rolled out
  • My workflow: I went into the Python command prompt in ArcGIS, activated my cloned environment with the arcgis package v1.5.2 and launched jupyter notebook from there. 


I'm able to log in and run other modules successfully. For example, '' returns successfully, but 'gis.admin.Credits.is_enabled' does not. 


any help would be greatly appreciated!





I was able to resolve the issue thanks to David J. Vitale. Created a new user account linked to a personal email, then made that user account an administrator. This way, I could log in without using OAuth2.0/without having to log in using my org's enterprise log-in system. When I did this, the gis.admin module appeared and worked without any issue.


I understand that the gis.admin module is only available if you are an admin. The API seems to be unable to detect that I'm an admin when signing in using OAuth2.0. Any chance of getting that sorted?