• How do I convert altitude to Mean Sea Level altitude?

    For whatever dumb reason, Android location altitude is WS84 altitude and not the one which most users expect, which is mean sea level altitude.   Can I make the conversion with ArcGIS Runtime? From WGS84 to EGM2...
    Crittermap
    last modified by Crittermap
  • Why is Offline Map from On Demand Workflow Missing Symbols?

    It's great that the Vector Style Editor now lets you edit symbols. However, this doesn't work when you download them offline through the OnDemand workflow.   All the symbols are gone. Not just the ones that we...
    Crittermap
    created by Crittermap
  • ArcGis map crashes randomly

    Hello,   I'm using version 100.4.0 of arcgis and I get sometimes random crashes with the following stacktrace :   E/AndroidRuntime: FATAL EXCEPTION: Thread-31 Process: xxx, PID: 32132 com.esri.arcgisrunt...
    worldline_csp
    last modified by worldline_csp
  • Migrating to 100.4.0 - Error Inflating Class - UnsatisfiedLinkError

    Hello, I am in the process of upgrading my project from ArcGIS 10.2.8-1 to 100.4.0, but I am having an issue inflating the layout. My project uses fragments and at the following line, my application is crashing:  ...
    sauegr01
    last modified by sauegr01
  • Invalid json when loading layer

    Here is how I try to load a FeatureLayer: override fun onCreate(savedInstanceState: Bundle?) {     super.onCreate(savedInstanceState)     setContentView(R.layout.activity_main)  ...
    tboebb
    last modified by tboebb
  • Map View in Fragment with Tab Action Bar

    I have an application that uses ActionBarSherlock and Tab navigation with the Android compatibility library. I have 4 fragments that are attached or detached with FragmentTransaction depending on the selected tab. On...
    bernieramelie
    last modified by bernieramelie
  • LocationDisplay not compatible with Android Location

    Am noticing that with the 100.4 LocationDisplay there is no longer a way to retrieve the number of satellites without setting up a separate Android location listener.   10.2.9 returns an Android Location L...
    jaarons47
    created by jaarons47
  • Set max envelope in 100 SDK for Android

    In the "old" SDK for iOS and probably also for Android you're able to set a max envelop on the map view to define a panning area for the map.   How do I do that in the 100 SDK for Android? Can't find any me...
    emilof
    last modified by emilof
  • Restrict map panning in ARCGIS Runtime SDK for Android

    Hi, I wan to restrict basemap to particular location,so for this want to restrict map panning.But I am unable to do so. (using version 100.4.0) Following code still doesn't work . as ' setMaxExtent  ' is s...
    supriyashah
    created by supriyashah
  • Input Spatial Reference is null when attempting to route

    I'm working with React Native and ArcGIS 100.4 for Android. While I was able to get routing working on the iOS side, it looks like Android is having issues. Here is the relevant code: public RNAGSRouter(Context contex...
    davidgalindo
    created by davidgalindo
  • JNI ERROR (app bug): weak global reference table overflow (max=51200)

    A few times a day, an ArcGIS Runtime app spontaneously dies while not doing much of anything. This error is in logcat.   JNI ERROR (app bug): weak global reference table overflow (max=51200)   According ...
    Crittermap
    created by Crittermap
  • Convert Queried Feature to ArcGIS Feature - ArcGIS Android SDK

    Hello Everyone, Given below are my scenario Query the service Url with object id then if it contains any attachment then display it and facilitate the user to add attachments. I have referred the samples and f...
    shanmeen1725@outlook.com
    last modified by shanmeen1725@outlook.com
  • Changing units from meters to degree decimals in ArcGIS?

    Hi Expert, We were trying to integrate ESRI to SAP Work Manager application. We refer "SAP® EAM and service mobile app SDK Installation Guide" for Building a GIS Client for Android. We successfully build the...
    paidipillshubham
    last modified by paidipillshubham
  • Is the SDK ready for 64 bit support?

    I got this message from Google Play about this:   Android Developers Blog: Get your apps ready for the 64-bit requirement    I was unable to tell if the ArcGIS Android Runtime 100.4 is ready for 64 bi...
    Crittermap
    last modified by Crittermap
  • How to decrease the app size

    I noticed that when I add the ArcGIS SDK to my app it almost tripled in size.  I mean even the simple HelloWorld app is like 40+mb in size.  So is there a way to cut some of the fat off the SDK that may just...
    jdwyer25
    last modified by jdwyer25
  • Accessing metadata when referencing a Portal Item?

    I am trying to display a web map I created online and am using a PortalItem to do this. It is working in the sense that I am able to view the map and the dots and lines however when I tap on a point or double-tap I ca...
    coracoleman14
    last modified by coracoleman14
  • When passing a MapView to a PopupContainer I am getting an error

    The error says that PopupContainer ('com.esri.arcgisruntime.mapping.MapView') in PopupContainer cannot be applied to ('com.esri.android.map.MapView'). Here is an image of the problem line and error message w...
    coracoleman14
    last modified by coracoleman14
  • help with displaying popups on map features in app?

    Below is my current implementation of this method for displaying popups from the latest ArcGIS Runtime for Android SDK, however I have come to a stopping point where you see below: showPopup(identifiedPopup, screenPo...
    coracoleman14
    last modified by coracoleman14
  • Android: Draw polygon by detecting paths in farms on base map satellite view in given extent

    In Android: I want to draw polygon automatically by detecting paths in farms on base map satellite view in given extent. Is it possible ?. For example I have Farm having multiple acres. When I mark Farm with a po...
    muhammad.younas
    last modified by muhammad.younas
  • Should we be moving off the 10.2.9 API and into the new 100.4.0?

    Hello   I wrote an application using the 10.2.9 API. However, I see that there is a 100.4.0 Runtime SDK for Android. Should we be using that instead now? Can I choose between one or the other? Thanks
    thomassldn
    last modified by thomassldn