withershin

Multiple Ring Buffer Input Error in Model Builder 10

Discussion created by withershin on May 3, 2011
Latest reply on May 10, 2011 by withershin
After 90 minutes of cursing and swearing I've discovered that if the input features to the multiple ring buffer does not exist then the Multiple Ring Buffer will not run in AG10.

I've attached a screen-shot. On the lower model branch I ran the Project(2) process and then I validated the entire model. Note the Multiple Ring Buffer goes white on the upper branch.

If you run these models from the 'Edit' mode then the model runs. If you run from the toolbox (open) then the following error is returned:

updateParameters Execution Error: Runtime error <type 'exceptions.IOError'>: C:\continents_basemap_Project.shp does not exist

I can easily recreate this error as the attached example was a recreation on my own machine after the aforementioned cursing and swearing period on a co-worker???s terminal on much more complex data.

Does anyone have a workaround that does not involve coding in Python? Python is not an option for my end users. Thanks.


-ArcGIS 10 SP2 (worked great in 9.3.1)
-Windows XP Pro SP3
-And yes I RTFM and yes I will make a call to ESRI in the morning

Attachments

Outcomes