schlot

Firefox problems loading a map for only some users?

Discussion created by schlot on Jun 25, 2014
Latest reply on Jun 26, 2014 by klapine
I have a map that works for most users in Firefox, IE and Chrome.  I have reports from a handful of users they can't properly open this map in Firefox, even when we have the same version of Firefox, in this case version 30. I believe it has to do with something in their Firefox browser, maybe a setting or permission, that is different than mine.  The majority of people who have tried it all report it opens just fine.  We've tried comparing our configurations, but haven't spotted anything yet that is different between computers.

They receive an error  ReferenceError: require not defined.

https://ogi.oa.mo.gov/MDA/ControlPoints/index.html

I have been told that I must use https for all maps, even though we only occasionally have something with any secure data.  I don't know if that is part of the problem or not.  I don't think this is something I can fix in the code.  I'm baffled what to tell these users, besides "use something besides Firefox".  It's worked fine on my computer through more than one upgrade to my Firefox browser.  Is there some thing we could look at in terms of Firefox settings that might help?

Outcomes