vdgm

Possible Error with JavaScript API 3.9 and AGS 10.2.2 - Feature Layer

Discussion created by vdgm on May 13, 2014
Latest reply on Feb 24, 2017 by adrian.fratila
I have an error with ArcGIS Server 10.2.2 and JavaScript API v3.9 adding a layer with Feature Layer. Initially the layer is loaded, but when browsing the map (pan, zomm, etc) the following errors appear in Chrome or IE:

Error {stack: "Error�?�    at Error (native)�?�    at Object.f.load (�?�)�?�    at http://js.arcgis.com/3.9/init.js:191:300", code: 400, message: "Unable to draw graphic (null): Failed to execute query.", details: Array[0], log: undefined�?�}
1. _ssl: undefined
2. code: 400
3. details: Array[0]
4. httpCode: 400
5. log: undefined
6. message: "Unable to draw graphic (null): Failed to execute query."
7. stack: "Error�?�    at Error (native)�?�    at Object.f.load (http://js.arcgis.com/3.9/init.js:629:424)�?�    at http://js.arcgis.com/3.9/init.js:187:69�?�    at c (http://js.arcgis.com/3.9/init.js:74:221)�?�    at d (http://js.arcgis.com/3.9/init.js:74:10)�?�    at resolve.callback (http://js.arcgis.com/3.9/init.js:75:350)�?�    at c (http://js.arcgis.com/3.9/init.js:74:436)�?�    at d (http://js.arcgis.com/3.9/init.js:74:10)�?�    at resolve.callback (http://js.arcgis.com/3.9/init.js:75:350)�?�    at http://js.arcgis.com/3.9/init.js:191:300"
8. __proto__: d


In AGS 10.2.2 the error is:

<Msg time="2014-05-12T18:12:57,121" type="SEVERE" code="9003" source="Rest" process="2112" thread="20" methodName="" machine="GIS" user="" elapsed="">Unable to process request. json</Msg>


The service was classified with a single symbology and not contains empty geometries.

This case also occurs with a other samples of AGOL, but with my AGS 10.2.2 https://developers.arcgis.com/javascript/jssamples/query_buffer.html

I have not found any ArcGIS AGOL Server with version 10.2.2 (only 10.21 or less found).


Thanks!

Outcomes