boyle.matt

Register SQL Spatial View using Esri Binary

Discussion created by boyle.matt on Apr 28, 2014
Latest reply on Apr 28, 2014 by vangelo-esristaff
Does anyone know how to register a SQL spatial view using a feature class that has Esri binary as its shape?

I have tried sdetable -o register and sdetable -o create_view but have been unsuccessful.  This could be because of my own lack of knowledge with the command line.

ArcSDE = 10.1
DBMS = SQL Server 2008 R2

Feature class name = lcbase.dbo.Parcels
Joined table name = gis.dbo.vw_parcels

Trying to create the view in a geodatabase called 'gisstaging'.

Below is the create_view command line prompt I've tried with an error (Error -162, Invalid Database Name)

sdetable -o create_view -T VWTest -t lcbase.dbo.PARCELS,gis.dbo.vw_parcelsweb -c lcbase.dbo.PARCELS.SHAPE,lcbase.dbo.PARCELS.GPNNUM,gis.dbo.vw_parcelsweb.GPN -w"lcbase.dbo.PARCELS.GPNNUM = gis.dbo.vw_parcelsweb.GPN" -i sde:sqlserver:lcgissql -D gisstaging -u **** -p ****


Below is the register command line prompt I've tried after creating the view in SSMS with an error (Error -144, Wrong Column Type, SE_table_get_shape_type failed) --- I'm assuming this is due to the Esri binary shape.

sdelayer -o register -l gisstaging.dbo.ParcelsSearch,Shape -e a -t geometry -i sde:sqlserver:lcgissql -s lcgissql -D gisstaging -u **** -p ****


Any ideas on how I can create a spatial view using an Esri binary feature class...?

Thanks in advance!

Outcomes