elvisds8

Raster format error

Discussion created by elvisds8 on Oct 3, 2013
Latest reply on Oct 4, 2013 by riamuyabu
Hello!
I have an issue when I run a process inside the model builder.
I run the tool "Make Raster Layer" to generate a one band raster layer from a satellite image, and the result is passed to a Python script that I have created.
The problem arises in the final lines of my python script, and here is the error report that appears:
Traceback (most recent call last):
File "C:\Users\eduran\Desktop\ArcGIS\Test_Process\scripts\reflectancia_banda.py", line 80, in <module>
arcpy.MakeRasterLayer_management(reflectance , "reflectance","","","")
File "c:\program files (x86)\arcgis\desktop10.1\arcpy\arcpy\management.py", line 6198, in MakeRasterLayer
raise e
RuntimeError: ERROR 010240: Could not save raster dataset to C:\Users\eduran\Desktop\ArcGIS\RasterFiles\Geobase.gdb\float_ras with output format FGDBR.

Failed to execute (Reflectancia).

"reflectance" is the one band raster layer multiplied by a constant value. Here is the line of my code that illustrates this:
reflectance = Float(Raster(Band)*prod)
As you can see this new raster cannot be saved. I have already moved the workspace to another Geodatabase, but I got the same problem.

Hope you can help me!
Regards.
Elvis Duran

Outcomes