crystalcarreon

Make Feature Layer Tool Not Working Properly!!

Discussion created by crystalcarreon on Feb 23, 2012
Latest reply on Feb 23, 2012 by curtvprice
Hello-
I have a tool which is doing the following:
1. taking a polygon file and figuring the centroid coordinates
2. exporting table to table
3. importing table and plotting the centroids.

As a parameter I have allowed the user to choose what fields they would like available in the final point file by using the make feature layer too however, the visible field option in the Make Feature layer is not working properly for the final output. The make feature layer is the very first tool in my model and, in theory, should erase the specified fields for the rest of the tool as the subsequent parts work off this feature layer. It works as it should for the table export as I don't see the fields I don't want. However, once the final output shapefile is generate somehow magically the fields are put back into the file but they are empty.

How do I get the model to not maintain the fields from the beginning of the model? It dosen't seem that model builder should be doing this at all. I have even tried putting the individual parts on the model in separate models and linking them together but it still won't let go of the original field schema. I have even hard coded the xy events layer tool to the table file on my computer in hopes that it wouldn't look at the intermediate data for the field schema but this didn't help either. I am loosing patience with model builder as it seems every tool I have tried in this model is not working how it really should. It is so fickle!

Outcomes