aorr

Reclass by ASCII File table format issue

Discussion created by aorr on Nov 17, 2011
Latest reply on Nov 18, 2011 by rdebruyn-esristaff
I've just gotten off of a 45 minutes phone call with Esri tech support and the issue I'm having has still not been resolved as of the time of this writing. He, nor I, have been able to troubleshoot this issue. Has anyone else had it or have any suggestions?

I'm using the Reclass by ASCII File tool of S.A. and have a raster that I need to remap values to.
The .txt file I'm trying to write has followed all of the guidelines posted on the help documentation screen but it still does not seem to be formatted properly. (http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/How_Reclass_By_ASCII_File_works/009z000000t3000000/)

The table I'm trying to use is simple for testing purposes:
# Example 1
# Remap of values.
100000 : 1
200500 : 1
201000 : 1
208000 : 1
209000 : 5
207000 : 99


I can run a table with strictly one entry on it, such as 100000 : 1 and the tool will work. I've tried everything from the notation above, to 100000 : 1 200500 : 1, etc. to 100000 :1, 200500 : 1.
Any way I write the .txt file the tool will return the following error:

ERROR 999999: Error executing function.
A column was specified that does not exist.
A column was specified that does not exist.
The table was not found. [VAT_Reclass_msu19]
The operation was attempted on an empty geometry.
ERROR 010067: Error in executing grid expression. Unable to initialize reclass table
Failed to execute (ReclassByASCIIFile).

Thanks for any assistance. And with any luck the Esri Tech support guy will call back with a solution.

-Andy

Outcomes