JoeDirt

Failure using model builder iteration to append many shapefiles

Discussion created by JoeDirt on Nov 1, 2011
Latest reply on Apr 5, 2017 by curtvprice
I have a very simple model set up with the goal of mining many shapefiles from nested folders and appending them into one shapefile. I am using the Iterate Feature Classes Iterator (recursive) to parse through the folders and feed the shapefiles into the Append tool. There are some columns in some of the shapefiles that are not used/do not match up so I'm using the "no test" option in Append to auto match the columns that can be matched. Using this setup I am getting all the shapefiles appended onto my target shapefile and the points plot on the map in the correct location but all the appended values are zero.

If I run the Append tool by itself using the same parameters for a handful of shapefiles it works fine. There is something I am missing between setting up the iterator and transferring the field values into the target shapefile. Is there a different iterator I should be using? I have tried iterate files and a couple other methods but nothing will let me run the append tool successfully other than Iterate Feature Classes.

I plan on using model builder for many upcoming tasks so I'd like to put in the time to understand how it works. Any help is appreciated.

Outcomes