piggie1230

create signatures error

Discussion created by piggie1230 on Oct 14, 2011
Hi all -

I'm using 9.3 on Windows 7.

I'm trying to create a signature file, but it's telling me that one of the rasters needs to be in integer format.  The problem is that all of the input rasters already are in integer format.  So I ran them through the int function just to make sure they were in integer format, and it's still spitting out the same error.  It's referring to what I'm assuming is a temporary file - in my temp folder, even though I specified a scratch workspace - so I don't have any control over what kind of file it is.  I can't see the raster in the temp folder, but I cleaned out my temporary files anyway, rebooted my machine a dozen times.  I was able to successfully create a signature file previously, but I specified the wrong sample field (and ended up with 0 classes), so I'm trying to fix it.  I deleted the old file and am using a unique name so I'm not really sure why it's doing this.

Does anyone know why it's doing this?

Outcomes