jazmateta

Address locator not working as a Python script

Discussion created by jazmateta on Jul 28, 2011
Latest reply on Jul 29, 2011 by jazmateta
Okay,
Have gotten several items to work with the python scripting now.  However, I have created a composite address locator that runs perfectly well in ArcMap.  When I run it as a python command, nothing matches.

snippets of code:
CAUfile = "caufile.txt"
AddLoc1 = "PointAddressLocator"
AddLoc2 = "StreetLocator"
AddComp = "CompositeLocator"
GeoColumn = "Address Adress VISIBLE NONE"

arcpy.env.overwriteOutput = True

arcpy.GeocodeAddresses_geocoding(CAUfile,AddComp,GeoColumn,wksp+"\Geoed")

I have tried it as well with GeoColumn = "Address"

Running Win7 x64; Arc10 SP1

The PointLocator uses single field of address
StreetLocator uses Address with nothing for the City

Thanks

ETA:  When running one of the address locators -point locator- by itself, it runs from python and matches.
Why can't you use a composite locator in Python?  That seems to defeat the purpose of allowing them in the first place.  There are many times when the data doesn't hit on one locator.  The data in this case is coming in as both single point addresses and as intersections.  And some of the addresses don't match exactly to the situs address we have in the system, but they do match as far as along a range on the street.

Outcomes