ali7789v4

IE issue - won't load points into a map from esri.request call

Discussion created by ali7789v4 on Jun 23, 2011
Latest reply on Jun 29, 2011 by hzhu
Hi

Everything works fine in all other browsers, but in IE (6,7,8) there's a problem.

Using IE8 and the Dev Tools, I get the following message:

Expected ';'  query?text=&geometry=&geometryType=esriGeometryPoint&inSR=&spatialRel=esriSpatialRelIntersects&relationParam=&objectIds=&where=1%3D1&time=&returnIdsOnly=false&returnGeometry=true&maxAllowableOffset=&outSR=&outFields=Operator%2CSector%2Ctotal_heat_load_kWt%2CHeat_Load_Taken_by_CHP_kWt%2CRemaining_Heat_Load_kWt&f=pjson&toJSON=function (key) %7B%0A                return this.valueOf()%3B%0A            %7D, line 2 character 22

It looks like IE thinks the syntax is wrong and I'm missing something, but I can't see any problems.

I've seen a similar thread here: http://forums.arcgis.com/threads/27453-Data-Access-Plain-Text-Sample-not-working but the solution doesn't work for me - I still get an error (in fact in all browsers!)

My code is this:
  var requestHandle = esri.request({
  url: "http://gisserver/ArcGIS/rest/services/6_WGSMSD/MapServer/5/query?text=&geometry=&geometryType=esriGeometryPoint&inSR=&spatialRel=esriSpatialRelIntersects&relationParam=&objectIds=&where=1%3D1&time=&returnIdsOnly=false&returnGeometry=true&maxAllowableOffset=&outSR=&outFields=Operator%2CSector%2Ctotal_heat_load_kWt%2CHeat_Load_Taken_by_CHP_kWt%2CRemaining_Heat_Load_kWt&f=pjson",
  content: "http://gisserver/ArcGIS/rest/services/6_WGSMSD/MapServer/5/query?text=&geometry=&geometryType=esriGeometryPoint&inSR=&spatialRel=esriSpatialRelIntersects&relationParam=&objectIds=&where=1%3D1&time=&returnIdsOnly=false&returnGeometry=true&maxAllowableOffset=&outSR=&outFields=Operator%2CSector%2Ctotal_heat_load_kWt%2CHeat_Load_Taken_by_CHP_kWt%2CRemaining_Heat_Load_kWt&f=pjson",
  load: requestSucceeded,
  error: requestFailed
   });

As you can see I'm trying to get a JSON output from one of my layers.

And then requestFailed is always being called. The message I'm getting back is:
{
"name":"Error",
"number":-2147352573,
"description":"Member not found",
"message":"Member not found"
}

But I can't seem to find any information on this in Google.

Is there a known issue in IE that has a simple fix to this problem?

And I've tried putting escape() around the URL in the esri.request, but that didn't work.

Grateful for any advice.

Outcomes