nhieuduong

cannot run arcgis engine jar file on unix machine

Discussion created by nhieuduong on Jun 3, 2011
Latest reply on Jun 23, 2011 by ebader-esristaff
we created a java program using arcgis engine 9.3 and packaged it in a jar file. when we use runtime 9.3 to execute the jar file on a windows machine , the program runs fine. however when we execute the same jar file on a unix machine (centos 5) we get a very ambigious error that points to a some code. i should add that we wrote the java program in windows..

so basically im wondering if you cant make the arcgis java program in windows and have runtime 9.3 run it in unix?

heres the error we get when we put execute it in the command line... ("java -jar Window3.jar")


Exception in thread "main" java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoader.java:58)
Caused by: AutomationException: 0x800a03e8 -
        at com.esri.arcgis.interop.NativeObjRef.init(Native Method)
        at com.esri.arcgis.interop.NativeObjRef.<init>(Unknown Source)
        at com.esri.arcgis.interop.Ocx.<init>(Unknown Source)
        at com.esri.arcgis.controls.MapControl.<init>(Unknown Source)
        at com.esri.arcgis.beans.map.MapBean.a(Unknown Source)
        at com.esri.arcgis.beans.map.MapBean.<init>(Unknown Source)
        at com.aor.mapping.Map.<init>(Map.java:353)
        at com.aor.seasimgui.MainWindow.<init>(MainWindow.java:260)
        at com.aor.seasimgui.MainWindow.main(MainWindow.java:634)


we tried using some sample jar files that arcgis provides and it gave us the same error. we sourced the init_engine.sh file first and even sourced the java one as well(init_java.sh) but nothing works..im hoping someone who has encounterd this before can shed some light as to what is going on.

thanks in advance to anyone who replies. any info even if its just brainstorming ideas is much appreciated...

Outcomes