jgcox

Cannot access any REST services: "Access to the temp directory is denied."

Discussion created by jgcox on May 19, 2011
Latest reply on May 21, 2011 by jgcox
Howdy,
I was recently forced to re-install ArcInfo and ArcServer after half the contents of my python26/arcgis10.0 folder were mysteriously overwritten. Since then, I have not been able to access any REST items. Manager thinks for a bit then gives me a blank screen, and rest/admin and rest/services both yield the same error message (appended below). I've tried uninstalling, deleting all the Arc user accounts, then re-installing. I've gone through and given IUSR and all re-established Arc user accounts access to every folder I can think of. Also I've added my user account, ISUR, and the Arc user accounts to the agsadmin group and just about all other user groups that seemed relevant. Still, it claims I don't have permission. Any idea what's going on?

many thanks,
jonathan cox


ERROR:
Server Error in '/ArcGIS/rest' Application.

Access to the temp directory is denied.
Identity 'IIS APPPOOL\ArcGISServicesAppPool' under which XmlSerializer is running does not have sufficient permission to access the temp directory. CodeDom will use the user account the process is using to do the compilation, so if the user doesnt have access to system temp directory, you will not be able to compile. Use Path.GetTempPath() API to find out the temp directory location.

Outcomes