AnsweredAssumed Answered

Quick Report new feature upload error after adding subtypes

Question asked by info@jaguar.com.co on Aug 8, 2020
Latest reply on Aug 9, 2020 by info@jaguar.com.co

Hi

 

I'm using Quick Report template on Appstudio, the reports were working ok, but after I added subtypes to the Feature Layer through ArcGIS Pro desktop, the reports are now generating an error at the upload page, and the data never arrives to the server, as seen on the right image (the error message in spanish in the next image says "Add new feature - Error"). This error appears equally on the desktop and in the Appstudio Player on iPhone. I tried without adding an attachment, but it doesn't work either. 

At some point of the development I compiled the Data Collection app (Data Collection | ArcGIS for Developers) in Xcode and when I run it on an iPhone it can connect to exactly the same Feature Layer URL and upload the reports without error (even including a photo attachment). That's why I doubt there is any configuration error of the Feature Layer. The next image shows the report being saved on Data Collection:

 

 

When I try to debug the Appstudio project in QT Creator, it shows these lines on the Debugger Console (I suppose the 405 error is the origin of the issue, but I can't be sure): 

 

 

I haven't found any other clue to solve the error, and given the fact that it works fine in the Data Collection app, I'm currently puzzled why this is happening. Any help will be appreciated

 

Oscar

Outcomes