AnsweredAssumed Answered

Unable to generate token for second ArcGIS Server instance added to an ArcGIS Server site

Question asked by jon.bailey on Mar 30, 2020
Latest reply on Mar 30, 2020 by jon.bailey

I've created a 3-tiered deployment of ArcGIS Enterprise 10.8 on Azure VMs (actually, it's 4-tiered if you count adaptor).

 

The following configuration is working correctly:

 

Web Adaptor (Portal) --> Portal --> Server --> Data Store

 

Next, I've added a second Server machine to my ArcGIS Server site. This all seems to work fine, except that when I attempt to log in to ArcGIS Server Manager on the second Server machine, the login hangs on the "Please wait..." progress dialog.

 

Looking at the network calls, the call to generate token:

 

https://webadaptor0/arcgis/sharing/generateToken?request=getToken
    &serverUrl=https://server1.[redacted].ux.internal.cloudapp.net:6443/arcgis/admin/info
    &token=jDVMyT9_nFo4CqCPyZ_K06FXaMqtb2KTfxYoMXp9xBxU50dIMCvoEel_sOLAL4wfJHhhVQFLxeZGszCUwy-J8OiyvhGPbV-KTb0b50ucum0nymjuwVw5LrS-w3ZWcjjPPJGIIiWK98fYjnCP0KOl4IulL7OJBsiwDO0LE2aLJq_5wVs4Ry6npKXdumvCD_B3I4NSNhulOy-ZXElYzv8XBvKiJiBBLX613CoTWGkakJI.
    &referer=server1.[redacted].ux.internal.cloudapp.net:6443&f=json
    &callback=dojo_request_script_callbacks.dojo_request_script10

responds with code 200, but the response payload is:

 

dojo_request_script_callbacks.dojo_request_script10(
{
    "error":
    {
        "code":400,
        "message":"Unable to generate token",
        "details":["Unable to generate token for this server"]
    }
});

This call returns as expected for the original Server machine.

 

So, why can't I get a token for this new machine?

Outcomes