AnsweredAssumed Answered

Sudden Slow Editing of Enterprise GDB Feature Class in ArcMap 10.7

Question asked by jrhoward on Jan 31, 2020

I have a large feature class stored in a versioned enterprise geodatabase (v 10.7 in SQL Server 2017, features stored as GEOMETRY). I have been working on these data for a few months with no problems. The data are building outlines, so lots of discrete polygons. Presently there are nearly 1.6 million records in the database. Until a couple of days ago, I was able to add new outlines easily using the ArcMap editing tools – fairly straightforward, with lots of rectangles and right angles. I then received a group of new outlines from a consultant and I set about pasting those in a bit at a time (I’m working off a review grid for my own sanity). Then after pasting in several new additions, amounting to a few tens of thousands of records, editing the data slowed to a crawl. Snapping became all but impossible. In trying to draw a new outline, several seconds would pass between adding a vertex and being able to add another vertex. I thought, “Well of course performance sucks, it’s time to compress.” Then having compressed, I saw no change in performance.

 

Here’s what I set about doing:

  1. I realized pretty quickly that I had exceeded the original extent of the feature class. OK, there’s a GP tool for that… Ran that, and the extent of the feature class didn’t budge. Tried to update it manually through ArcCatalog. Same. Finally updated it in the spatial index in SQL Server… made no difference.
  2. Rebuilt the spatial index. No change in performance. Delete the spatial index and rebuild it. No change in performance. Rebuild the spatial index in SQL Server. No change in performance.
  3. Recalculated statistics and rebuilt the only index on the feature class (ObjectID). No change in performance.
  4. Compressed to State Zero. I had my editors reconcile, post, and delete their working versions until I was done cleaning up. I then recreated our version environment… default at the top with a QAQC version below and all editing versions as children of QAQC. No change in performance.
  5. I created a new feature dataset in the same database and copied the data into that. The copied feature class performed the same.
  6. I created a copy of the feature class in a completely different database. The copied feature class performance the same.
  7. I tried creating an empty feature class and loading the features into that (I’m grasping at this point). No change.
  8. I ran a Sort based on the Shape field to see if that did anything. Besides making the feature class render in a satisfying north to south progression… I tried deleteing any feature with curves...  I tried turning it off and on again.  Nada.
  9. Tried editing in ArcGIS Pro… unsatisfying in its own way and not really an improvement anyway.
  10. I kicked the feature class out into a file geodatabase… AHA! Back to good ol days of drawing rectangles! However, I don’t want to maintain these data outside of the enterprise GDB, if at all possible.

 

What have I overlooked?!

Outcomes