AnsweredAssumed Answered

Using a field attribute in a webpage parameter from Survey123 on Experience Builder

Question asked by jollyrojerr on Jan 8, 2020

 I currently have a list with features from a Survey123 poll and am having an issue trying to use a field within a webpage parameter in a textbox on Experience Builder

 

I want to create a button with a link that utilizes webpage parameters that will direct users to the respective Survey123 submission form for editing(more info on webpage parameters in MapViewer on the blog post here). Ideally this would be a button or a hyperlink. To my knowledge, the expression builder for the button widget does not support incorporating text and fields together so this would not be possible. I opted to create a textbox instead, below is the textbox used that tries to call the field {ObjectId} (towards the end of the link):

This textbox produces the following links on the list shown below:

This text displayed is exactly what I wanted, however the hyperlink does not work. The hyperlink stops exactly when the line hits {ObjectId}. Notice in the image below how the hyperlink underline ends after object= , this sends users to the wrong link when clicking. I have tried typing out the link instead of pasting it into the textbox but the hyperlink still ends at {ObjectId}

I am able to successfully create these links in the Custom Attribute Display when configuring feature pop-ups in MapViewer using the same method. Is there a work around to this to fix the hyperlink so that it includes {ObjectId} into the hyperlink? Or if someone can explain how to do this for the button widget in the expression builder that would help as well. I am using the Experience Builder Online version, thanks in advance.

Outcomes