AnsweredAssumed Answered

Problem Installing ArcGIS Enterprise on Linux (CentOS 7)

Question asked by leonilindro on Dec 26, 2019
Latest reply on Dec 31, 2019 by JQuinn-esristaff

Hello friends,

 

I am having a real hard time deploying ArcGIS Enterprise 10.6.1 on Linux (CentOS 7). The online help article and installation guides I feel are very disjunct. Earlier I have deployed ArcGIS Enterprise 10.6.1 on Windows 10 Pro, which was a 1000 times easier. I must also mention that I am new to the Linux environment.

 

After reading all the material available, I have done all the pre-requisite configurations. I have installed Apache 2.4.6 (CentOS), Tomcat 7.0.76, Server 10.6.1, and Portal 10.6.1. I face the main problem while installing the Web Adaptor Java Linux 10.6.1. Various installation guides asks to install separate Web-adaptor with different names (portal and server), but unlike the windows Web-adaptor IIS setup the linux Web-adaptor Java setup doesn't ask to name your adapter.

 

After installing the java linux web-adaptor, I deployed the arcgis.WAR file from my Tomcat Web Application Manager (deployed WAR file.png), opened the Web-adaptor by clicking on the link from the list of Applications (opened the web adaptor.png) in Tomcat and configured the Web-adaptor for Server. I should now configure it for Portal, right? When I would try it before I configured it for Server, it wouldn't let me, saying that I need to host a website from my web server's port 80 first (which I believe I already had). Now when I click the "arcgis" web adapter link in the Tomcat App Manager, after having configured for server, it takes me to the ArcGIS REST Services Directory.

 

I am a loss. I am unable to figure out how to install web-adaptor separately for server and portal in linux.

 

We really need a step-by-step guide (PDF) with pictures at least for a base deployment of ArcGIS Enterprise on Linux.

Outcomes