AnsweredAssumed Answered

Model Builder: Iterate Workspace not working...

Question asked by mmolloy_cc on Dec 12, 2019
Latest reply on Jan 8, 2020 by rwadej2

Hi there,

 

I created a model in ArcPro that will delete features (ex. drainage areas) that intersect with unfeasible landcover classes within a raster (ex. impervious). So I used the following model structure: Reclassify --> Raster to Polygon --> Select By Location (Intersect) --> Delete Features.

 

This model worked fine when I tested it on one geodatabase's data - but when I try to Iterate Workspace to apply the model to all 73 geodatabases, it cannot figure out where the input feature data is. Each geodatabase has the same data naming conventions within it but with different geodatabase id numbers at the end (ex. M3_drainage_huc_#). So the input features I use for Select by Location look like this ex: %Path%Name%M3_drainage_huc_%HUCNumber%

 

But as you can see in the screenshot below, it doesn't recognize where they are.

 

Any ideas as to why this might be happening? And/or ways to work around this issue?

 

Thank you!!!

 

P.S. Sorry if I didn't explain my question well enough--I tried not to make it confusing, but let me know if you need any clarifications.

 

 

Outcomes