AnsweredAssumed Answered

Unable to read Sqlite non-spatial with Data Interoperability

Question asked by sean_airmap on Oct 4, 2019
Latest reply on Oct 16, 2019 by bharold-esristaff

How come the Sqlite non-spatial reader in Data Interop requires a database connection that doesn't let you specify sqllite non-spatial? If you choose the only sqlite option (spatial) , the connection remains red and doesnt let you read data.

 

Steps to repro

 

  1. Add a new reader
  2. Choose sqlite non-spatial
  3. Select a database
  4. Click Parameters (since you have to because it is red)
  5. In the database dropdown, choose the only Sqlite option (Sqlite Spatial)
  6. Give it a name and specify database

If you test it will say it isn't licensed. I do not see any way sqlite  non spatial db can be read

 

ArcGIS Pro 2.4.1

Outcomes