AnsweredAssumed Answered

Importing ArcPy Crashes Python Interpreter

Question asked by nathanheick@lacsd.org on Sep 19, 2019
Latest reply on Mar 3, 2020 by bixb0012

I am getting the following error when trying to import arcpy or arcgis from a stand-alone Python script either run from IDLE for Python 3 or through the Conda Python interpreter that comes with ArcGIS Pro:

 

Faulting application name: pythonw.exe, version: 3.6.8150.1013, time stamp: 0x5c6f5f72

Faulting module name: GpPythonCore.dll, version: 12.4.0.19948, time stamp: 0x5d0ad153

Exception code: 0xc0000005

Fault offset: 0x000000000000a4ad

Faulting process id: 0x4ce0

Faulting application start time: 0x01d56e6b54efb586

Faulting application path: C:\Program Files\ArcGIS\Pro\bin\Python\envs\arcgispro-py3\pythonw.exe

Faulting module path: C:\Program Files\ArcGIS\Pro\bin\GpPythonCore.dll

Report Id: 5f5e420e-e05b-48d1-9985-a969e646b5b3

Faulting package full name:

Faulting package-relative application ID:

 

Everything was fine up until the following occurred.  I was trying to use Pandas data frames in a stand-alone Python script.  I was writing the script in Wing IDE, but I had not figured out how to set up the Wing project to use Python 3.  Therefore, I was opening the script up in IDLE to run it. I was in the process of switching from using NumPy arrays and Pandas data frames to using spatially-enabled data frames.  I added the imports to use SEDFs and I had some sort of error.  I decided it was time to setup my Wing project to point to Python 3 instead of 2.  I did research online and I believe I copied the path to the root environment Python interpreter and pasted it into the settings in Wing.  After that, when I went to run it, python.exe crashes.  It crashes from Wing, IDLE, and the command prompt.  It does not, however, crash from the root python command line or ArcGIS Pro.  I isolated the problem down to the import statement and I am just typing in import arcpy or import ArcGIS from the Python command line.

 

I tried to reinstall ArcGIS Pro, then both ArcMap and ArcGIS Pro, and neither worked.  I uninstalled Wing IDE and I am only trying to get basic ArcGIS Pro functionality to work.

 

I am hoping someone has some insight.

Outcomes