AnsweredAssumed Answered

Installing untools on ArcGIS Pro 2.4 behind a corporate firewall / proxy

Question asked by hbijkeresri-southafrica-esridist Employee on Aug 19, 2019
Latest reply on Dec 6, 2019 by wboothesriaustralia-com-au-esridist

Hello All

 

We have a client trying to install the utility network on an ArcGIS Pro v 2.4 instance on a computer that is behind a corporate firewall/proxy that seems to be blocking out access to the files required to install the utility network tools.

 

What we have tried so far:

1. Clone the arcgispro-py3 environment to a new environment arcgispro-py3-clone and make that the default environment -> success!.

2. Installing from ArcGIS Pro Python packages "untools".  -> This fails silently without any error messages.  We do not see the package as installed.

3.  Open a Python command prompt with elevated privileges and try to use conda install untools -> Fails with an error message that it cannot connect to repo.anaconda.org.  When we try the URL in a web browser we can see the JSON of the configuration coming back.

4. Create a .condarc file in the users home directory and add the proxy servers to the file as follows 

proxy_servers:          http: http://proxy.domain.com:8080
         https: https://proxy.domain.com:8080

 we then try to run the conda install untools command again and get the same error message that we cannot connect to  the repo.anaconda.org

5. We then try to use the CNTLM Cntlm: Fast NTLM Authentication Proxy in C  authenticating proxy, generate hashes for it  and run it as a standalone program.  We point the .condarc to the CNTLM authenticating proxy an run the conda install untools command again.  Here we get an authentication error on the proxy although we know that the username and password is correct.

 

We are very much out of ideas at this point and would appreciate any input from fellow users who may have run into this.

 

Thank you.

Outcomes