AnsweredAssumed Answered

Consistent processing failure immediately after substep Camera Calibration?

Question asked by cymrych79_G_P on Mar 30, 2019
Latest reply on Apr 15, 2019 by cymrych79_G_P

So far in my trial of D2M, I've only managed to complete one 2D project. Since then, I consistently get an Unknown Exception Error which according to the log occurs immediately after (or during?) substep Camera Calibration during the initial processing phase. It happens whether I am attempt to produce purely 2D products at about the 29% completion mark, or 3D products, although the exception error seems to occur later in the processing of a purely 3D products attempt at 80% completion. I've attempted multiple slight variations of processing options, mostly adjusting keypoint imaging scale and targeted number of keypoints, but also with the full default options as used with my one and only successful processing attempt (the first dataset processed). I have no yet attempted to reprocess an identical dataset as my one successful processing attempt to see if the problem now occurs there too, as that dataset is quite a bit larger and it would take roughly 5 hours or so to reach the failure point.

 

Here is the relevant section from the log: 

2019-03-30 00:56:20,513 INFO - {"exit":{"code":"0","errorMessage":""},"status":{"currentStep":"initial","detailedMessage":"Compute number of matches.","overallProgress":"24","substep":"Georeference the model"},"timestamp":"1553921780513"}
2019-03-30 00:56:20,746 INFO - {"exit":{"code":"0","errorMessage":""},"status":{"currentStep":"initial","detailedMessage":"Substep Georeference the model finished.","overallProgress":"24","substep":"Georeference the model"},"timestamp":"1553921780746"}
2019-03-30 00:56:20,750 INFO - {"exit":{"code":"0","errorMessage":""},"status":{"currentStep":"initial","detailedMessage":"Substep Camera calibration started.","overallProgress":"29","substep":"Camera calibration"},"timestamp":"1553921780748"}
2019-03-30 00:56:24,973 INFO - {"exit":{"code":"0","errorMessage":""},"status":{"currentStep":"initial","detailedMessage":"Substep Camera calibration finished.","overallProgress":"29","substep":"Camera calibration"},"timestamp":"1553921784972"}
2019-03-30 00:56:25,099 INFO - {"exit":{"code":"1","errorMessage":"Caught unknown exception during initial processing!"},"status":{"currentStep":"initial","detailedMessage":"Substep Camera calibration finished.","overallProgress":"29","substep":"Camera calibration"},"timestamp":"1553921785099"}
2019-03-30 00:56:25,123 INFO - {"exit":{"code":"1","errorMessage":"Caught unknown exception during initial processing!"},"status":{"currentStep":"initial","detailedMessage":"ProjectLoaded","overallProgress":"29","substep":"Camera calibration"},"timestamp":"1553921785123"}
2019-03-30 00:56:25,150 INFO - {"exit":{"code":"1","errorMessage":"Caught unknown exception during initial processing!"},"status":{"currentStep":"initial","detailedMessage":"Aborting ...","overallProgress":"29","substep":"Camera calibration"},"timestamp":"1553921785150"}

Any help is greatly appreciated. Thanks --Jason

Outcomes