AnsweredAssumed Answered

Survey submit fails with a table-feature class relationship

Question asked by flspat on Mar 28, 2019
Latest reply on Apr 3, 2019 by flspat

Hi All,

Sort of new to Survey123 so I might be missing something simple or doing something beyond the capabilities...Here's what I've got:

 

Created a polygon feature class and table (the survey columns) in ArcCatalog along with a Simple, 1-Many relationship class between the feature (polygon 1) and table (many) using the GlobalId as the linking column.  This setup is then published to our online org account as a host feature layer.  I don't have any issues editing data in either the file geodatabase with ArcMap locally or the hosted feature layer via JavaScript API or map viewer.  

 

Created a Survey123 with Connect (3.4.29b) using the feature service as the template.  Used xls to modify the columns, submission url and form id to the correct values.  Saved and loaded the xls. Published the survey.  Everything seems fine there. 

 

When I run the survey from the web site form (not the device app - haven't tried that yet), all good until the submit.  Submit fails with error:

 

- Operation rolled back. Operation rolled back. Incorrect geometry type.

 

Which seems odd since I shouldn't be submitting any geometry to the table.  

 

Watching the network tab in chrome shows the applyedits operation to the hosted feature layer.  Sure enough, it's adding a feature to the polygon layer with an (0,0) point.  The feature json to the table is correct.  I can copy and paste it to the REST pages and get a successful insert.  So I'm not sure why the survey is trying to submit a record to the polygon layer.  I don't have geopoint column in the XLS but it does have one listed in the "schema" tab of the Connect app.  I can't find a way to delete it there.  

 

Is there some other setting to tell the survey to skip any geometry edits?  Is the explicit relationship class causing some sort of problem?

 

Thanks for the help.

Outcomes