minerjoe

AGOL Offline Map Sync Issues

Discussion created by minerjoe on Mar 14, 2019
Latest reply on Mar 15, 2019 by minerjoe

We have had ongoing issues with sync using on offline map approach.  The errors do seem to be isolated to specific services but we have redone these services and the issues still seem to persist with the new services so I don't think it is an issue with the service.

 

I changed to use the JobProgress handler so we could get all the posted messages and here is what we see (does not seem very informative)

 

Message is in the form:

$"{jobMessage.Severity}: {jobMessage.Source}: {jobMessage.Message}"

 

2019-03-14 15:53:30,501 Warning: Client: Sync geodatabase: Failed: "Job error 22 User defined failure. Error while handling get server sync job status. Job error 500 Unable to synchronize replica. Sync replica internal error - 426a7c13-bddf-4079-8f82-d9918c71c5dc."
2019-03-14 15:53:30,501 Warning: Client: Sync geodatabase: Failed: "Job error 22 User defined failure. Error while handling get server sync job status. Job error 500 Unable to synchronize replica. Sync replica internal error - 65c341b6-2e76-4757-960f-6ff0ddbcc5ab."
2019-03-14 15:53:30,501 Warning: Client: Layer result: Sync failed. Name: Reference Line LayerID: 1 TableName: Reference_Line URL: https://services3.arcgis.com/S8sRvG5IBCRdqu9T/arcgis/rest/services/Reference_Line/FeatureServer/1 Job error 22 User defined failure. Error while handling get server sync job status. Job error 500 Unable to synchronize replica. Sync replica internal error - 65c341b6-2e76-4757-960f-6ff0ddbcc5ab.
2019-03-14 15:53:30,501 Warning: Client: Layer result: Sync failed. Name: Service Pipe LayerID: 0 TableName: Pipeline_Line URL: https://services3.arcgis.com/S8sRvG5IBCRdqu9T/arcgis/rest/services/Pipeline_Line/FeatureServer/0 Job error 22 User defined failure. Error while handling get server sync job status. Job error 500 Unable to synchronize replica. Sync replica internal error - 426a7c13-bddf-4079-8f82-d9918c71c5dc.

 

I have confirmed that the replicas does exist in AGOL and there is nothing that would seem incorrect about the replica definition:

 

 

Replica Info
Replica Name: MyReplica_485
Replica Id: 65c341b6-2e76-4757-960f-6ff0ddbcc5ab
Replica Owner: rwallace_atw
Target Type: client
LayerServerGens: [{"id":1,"serverGen":128010}]
Creation Date: 3/8/2019 3:11:38 PM
Last Sync Date: 3/8/2019 3:11:38 PM
Sync Model: perLayer
Return Attachments: True
Attachments Sync Direction: bidirectional
Spatial Relation: Intersects
geometry Polygon:
Ring0:[2019084.28533725,14707684.8862801],[2019084.28533725,14708059.7287062],[2019085.35587563,14708092.4302709]...98 more...

Layers: 1
Id: 1
Query Option: useFilter
Use Geometry: True
Include Related: True
Where:
Spatial Reference:102100

 

Any Ideas?

Michael Branscomb

Outcomes