AnsweredAssumed Answered

Layer Data Source Not Recognized with Server

Question asked by pmccord_wayne on Feb 7, 2019
Latest reply on Mar 8, 2019 by tpcolson

I'm attempting to publish a map service to ArcGIS Server from ArcMap. But when I Analyze within the Service Editor before publishing, I receive the warning "Layer's data source is not registered with the server and data will be copied to the server."

 

However, I have registered my geodatabase with the server, and when I validate my connection in both ArcCatalog and ArcGIS Server (in the Server Manager), I receive a green check mark next to my database indicating that I've registered my data with the Data Store.

 

The network that I'm working on is one where my desktop computer is where I am running ArcGIS Desktop (ArcMap and ArcCatalog), a separate machine in our network is where the Enterprise Geodatabase resides (where I am accessing the data for the Map Service), and a third machine is running ArcGIS Server.

 

I think the attached schematic is essentially the same configuration that I have when registering my data. This schematic was taken from https://enterprise.arcgis.com/en/server/10.5/publish-services/linux/overview-register-data-with-arcgis-server.htm ("About Registering your data with ArcGIS Server" help file).

 

Could the issue be that somehow my connections between the three machines are untrusted and causing this warning? I'd really like to publish my service without copying the data to the server.

Attachments

Outcomes