AnsweredAssumed Answered

MapView.js "Object doesn't support this action" - Internet Explorer 11 and JSAPI 4.8

Question asked by csgeosol1 Champion on Sep 17, 2018
Latest reply on Sep 18, 2018 by csgeosol1

Hello all,

 

Is there a known issue with IE 11 and v4 of the JSAPI? Specifically, I stripped everything out of my application and found there is an issue with MapView, for IE, but not Chrome:

 

<!DOCTYPE html>
<html>
<head>
<meta charset="utf-8">
<meta name="viewport" content="initial-scale=1,maximum-scale=1,user-scalable=no">
<title>IE Issue</title>
<style>
html,
body,
.embeddedMaps {
padding: 0;
margin: 0;
height: 100%;
width: 100%;
}
</style>
<link rel="stylesheet" href="https://js.arcgis.com/4.8/esri/css/main.css">
<script src="https://js.arcgis.com/4.8/"></script>
<script>
require([
"esri/Map",
"esri/views/MapView",
"dojo/domReady!"
], function (Map,
MapView
) {
const map = new Map({
basemap: "gray-vector"
});

const view = new MapView({
container: "myMapContainer",
map: map,
zoom: 9,
center: [-82.457, 27.95]
});
});
</script>
</head>
<body>
<div class="embeddedMaps" ID="myMapContainer"/>
</body>
</html>

 

IE is reporting the issue in MapView.js on line 806:

 

SCRIPT445: Object doesn't support this action

 

...
g(function () {
       d.dispatchEvent(new MessageEvent("message", { //error here...
             data : b
       }))
})
...

 

It seems it's choking on MessageEvent(), but according to MessageEvent - Web APIs | MDN  - it is supported.

 

Any ideas? This is a big deal for us as IE support is REQUIRED for our app, unfortunately. This IS working in Edge, it appears.

 

Thanks!

Outcomes