AnsweredAssumed Answered

Issue debugging Survey 123 Connect (Template) in QT Creator

Question asked by lmccallumesri-ca-esridist Employee on Sep 12, 2018
Latest reply on Sep 27, 2018 by lmccallumesri-ca-esridist

Hi

 

I've followed the steps outlined here to debug the template in QT Creator (Community Edition)

Debug JavaScript in Qt Creator—AppStudio for ArcGIS | ArcGIS 

 

When trying to run the debug on the out of the box survey 123 template, I get the following errors from Qt Creator 

 

13:58:21: Debugging starts

13:58:21: Starting C:\Qt\5.10.0\msvc2017_64\bin\qmlscene.exe C:/Users/myuser/ArcGIS/AppStudio/Apps/7d2b8e83c9e44cd4b9e511757e9849d5/Survey123Connect.qml "-qmljsdebugger=port:51225,block,services:DebugMessages,QmlDebugger,V8Debugger,QmlInspector"

QML Debugger: Waiting for connection on port 51225...

ArcGIS.AppFramework.Plugin: void __cdecl AppFrameworkPlugin::registerTypes(const char *) ArcGIS.AppFramework

ArcGIS.AppFramework.Plugin: void __cdecl AppFrameworkPlugin::initializeEngine(class QQmlEngine *,const char *) ArcGIS.AppFramework

ArcGIS.AppFramework.Plugin: void __cdecl AppFrameworkPlugin::initializeEngine(class QQmlEngine *,const char *) Offline storage path: "C:\\Users\\myuser\AppData\\Local\\QtProject\\QtQmlViewer\\QML\\OfflineStorage"

ArcGIS.AppFramework.Plugin: void __cdecl AppFrameworkPlugin::initializeEngine(class QQmlEngine *,const char *) CoInitializeEx failed: -2147417850

ArcGIS.AppFramework.Plugin: void __cdecl AppFrameworkPlugin::initializeNetwork(void) Using system network proxy configuration

ArcGIS.AppFramework.Image: void __cdecl ImageProvider::initialize(class QQmlEngine *) QQmlEngine(0x79b7aff0f8)

ArcGIS.AppFramework.Image: __cdecl ImageProvider::ImageProvider(class QFlags<enum QQmlImageProviderBase::Flag>) QFlags()

Registering QML types: ArcGIS.AppFramework.Desktop

Initializing QML engine: ArcGIS.AppFramework.Desktop

ArcGIS.AppFramework.Sql.Projection: void __cdecl Proj4::initialize(void) PJ_VERSION: 493

ArcGIS.AppFramework.Sql.ST: class QString __cdecl ST_Projection::lookupDef(int) 4326 = "+proj=longlat +ellps=WGS84 +datum=WGS84 +no_defs"

file:///C:/Users/myuserArcGIS/AppStudio/Apps/7d2b8e83c9e44cd4b9e511757e9849d5/Survey123Connect.qml:19 Type ConnectApp unavailable

file:///C:/Users/myuser/ArcGIS/AppStudio/Apps/7d2b8e83c9e44cd4b9e511757e9849d5/Connect/ConnectApp.qml:214 Type TutorialsTab unavailable

file:///C:/Users/myuser/ArcGIS/AppStudio/Apps/7d2b8e83c9e44cd4b9e511757e9849d5/Connect/TutorialsTab.qml:19 plugin cannot be loaded for module "QtWebView": Cannot load library C:\Qt\5.10.0\msvc2017_64\qml\QtWebView\declarative_webview.dll: Th

e specified module could not be found.

 

13:58:23: Debugging has finished

 

13:52:41: Debugging has finished

 

 

Outcomes