AnsweredAssumed Answered

Predetermined Answer using URL not working with Choice Filter

Question asked by erick.wiggs on Aug 6, 2018
Latest reply on Aug 6, 2018 by JHasthorpe-esristaff

This might be a bit of a stretch, but here it goes.

 

I have set up a choice filter that limits my INCIDENT_TYPE_ID based on my SWF_STATUS:

active=${SWF_STATUS}

 

The appearance of my INCIDENT_TYPE_ID is set to minimal (as per other question entry suggestions).

 

I am passing data from an address feature service with a one to one related table:

arcgis-survey123://?itemID=(SURVEYid)&field:SWF_RATE={relationships/0/SWF_RATE}&field:MLGW_STATUS={relationships/0/ACCT_STATUS}&field:SWF_STATUS={relationships/0/SWF_STATUS}&field:INCIDENT_TYPE_ID=10507&field:ADDRESS1={FULL_ADDRESS}&field:X={Y}&field:Y={X}&field:INCIDENT_AREA={SWM_AREA}&field:ZONE={SWM_ZONE}&field:COLLECTION_DAY={SWM_DAY_NO}&field:ROUTE={SMW_ROUTE}&field:PREM_CODE={PREM_CODE}&field:PARCEL_ID={PARCELID}

All of this is working fine, save for one point.

 

I would like to pass a predetermined INCIDENT_TYPE_ID for the ease of my end user.

&field:INCIDENT_TYPE_ID=10507

However, with the choice filter in place it's not accepting the predetermined number from the URL.

 

Seems crazy, I know. But here me out. 

The predetermined work flow is set to generally create a Picker Pile, except for when a location is set to Inactive, and then I need them to manually chose a Code Violation (different INCIDENT_TYPE_ID). What I would like to happen is that I pass along the predetermined Picker Pile INCIDENT_TYPE_ID until the choice filter activates due to an Inactive SWF_STATUS, in which case the INCIDENT_TYPE_ID fails and they have to manually pick from the Inactive choice list.

 

Thoughts??

 

I'm currently using Survey123 Classic as (for other reasons) I can not activate GUID.

Attachments

Outcomes