AnsweredAssumed Answered

Need help with creating multimodal network and error with Add GTFS to a Network Dataset Step 2.

Question asked by contactdestiny on Apr 26, 2018
Latest reply on May 10, 2018 by MMorang-esristaff

I am a college student looking to create a multimodal network so that I can locate the best restaurants in the area within 5-7 minutes walking distance from my school and within 10-15 minutes of MTA public transportation. I downloaded the following data from http://transitfeeds.com/:


1. Metro-North Railroad GTFS 
2. MTA Manhattan GTFS 
3. NYC Bus Company GTFS 
4. NYC Subway GTFS
5. NYC Subway Supplemented GTFS

 

I also downloaded the NYC street data from the following source: 

https://data.cityofnewyork.us/City-Government/NYC-Street-Centerline-CSCL-/exjm-f27b/data

 

I created a geodatabase for these files under the feature dataset TransNet. I added the NYC street data to the dataset. I downloaded the "Add GTFS to a Network Dataset" tool to aid me in creating a multimodal network from this data above. The first step, "Generate transit lines and stops," was executed successfully in ArcCatalog 10.6 and added the two feature classes "TransitLines" and "Stops" to the feature dataset for all the GTFS files above I put into the tool. However, for step 2, "Generate Stop Street Connectors," the tool produced the following error at step 8 of 14 for the wheelchair portion:

 

Messages:
Executing: GenerateStop2StreetConnectors C:\Users\Leah\Downloads\HCBestRs18BU.gdb\TransNet C:\Users\Leah\Downloads\HCBestRs18BU.gdb\TransNet\NYCStreets # 40 Meters
Start Time: Thu Apr 26 20:50:29 2018
Running script GenerateStop2StreetConnectors...
Snapping stops to streets network...
Creating connector lines between stops and streets...
Handling wheelchair_boarding...
Creating vertices in streets at location of stops...
(This step might take a while.)
Failed to generate stop-street connectors.
Failed script GenerateStop2StreetConnectors...

Traceback (most recent call last):
File "c:\program files (x86)\arcgis\desktop10.6\ArcToolbox\Toolboxes\scripts\GenerateStop2StreetConnectors.py", line 289, in <module>
arcpy.management.Integrate([[outStreetsSplit, 1], [TempSnappedStops, 2]])
File "c:\program files (x86)\arcgis\desktop10.6\arcpy\arcpy\management.py", line 2128, in Integrate
raise e
ExecuteError: ERROR 999999: Error executing function.
Invalid Topology [Negative point valence.]
Failed to execute (Integrate).


Failed to execute (GenerateStop2StreetConnectors).
Failed at Thu Apr 26 21:11:26 2018 (Elapsed Time: 20 minutes 56 seconds)

 

I used the check geometry tool to make sure something wasn't wrong with the three feature classes now in the dataset, and only the NYC street data came back with short line segment errors. I used the repair geometry tool to get rid of them. Then, I ran the tool again and got the same error. I am at a loss on how to fix this. If it cannot be fixed, can I still use it to create my network? 

 

Thank you!

Outcomes