AnsweredAssumed Answered

Is there a fix for the 'Unable to find ArcGISRuntime deployment folder' error?

Question asked by rwebster_pinellas on Mar 29, 2018
Latest reply on Apr 2, 2018 by aoprdid

A major project of mine has developed this error.  This started when I was working in Visual Studio 2015.  I have since reloaded the Nuget packages, reloaded the SDK, Installed the newest version of Visual Studio (2017), built a brand new trivial app that just tries to display a map in a user control and more or less tried everything.  There was a recent question about it, but it wasn't helpful.   Nothing I do fixes the problem...  

 

This is at design time and it's a visual basic app.  Anything I try all boils down to the same error...

 

Error initializing ArcGISRuntimeEnvironment. Unable to find ArcGISRuntime deployment folder. Ensure there is a folder named "arcgisruntime100.2" in the same folder as your application executable, or set ArcGISRuntimeEnvironment.InstallPath to reference an alternative location. The deployment folder must contain sub-folders matching the process architecture of your application.

 

 

The deployment folder is there.  And... I can compile my application and it runs perfectly!  But at design time, it can't render my main form, and instead gives the above error.   I have attached an image of what Visual Studio does when I try to load the form that hosts the WPFMap user controls.  I am dead in the water.  At this point, I may have to move to a different development machine and try a clean install of Visual Studio and the .net SDK.



Attachments

Outcomes