AnsweredAssumed Answered

Python API: TypeError on geometry column for Spatial DataFrame of local data source

Question asked by Ryan.Cooper@raleighnc.gov_ral on Mar 27, 2018
Latest reply on Mar 28, 2018 by rsingh-esristaff

At the DevSummit, I learned that you could load a feature class from a local source into a Spatial DataFrame using the ArcGIS API for Python. Specifically, the documentation implies this can be done using the from_featureclass() method in the features module to create a Spatial DataFrame. I followed the example in this notebook for loading a local shapefile into a Spatial DataFrame (sdf).

 

I am using Jupyter Notebook as my IDE. My environment is the default arcgispro-py3 environment from ArcGIS Pro. I know I am able to successfully create a Spatial DataFrame objectbecause when I run the object through the type() function in my Jupyter Notebook I get the following:

arcgis.features._data.geodataset.geodataframe.SpatialDataFrame

I am able to return  sdf.head() and sdf.describe() without issue.

However, if I run sdf.info() I get the following error:

I have tried this on point, line and multipolygon shapefiles, and file GDB feature classes. All locally loaded data eventually returns this error. I am able to successfully create Spatial DataFrames from AGOL data and do not receive the error above when running sdf.info().

 

The documentation and examples I've been able to find about properly loading local data into a Spatial DataFrame seems pretty scattered and undeveloped at the moment. Looking at this error and the process I've described, does anyone have any suggestions on how I might troubleshoot this further? Thanks!

Outcomes