AnsweredAssumed Answered

GeoForm Confusion

Question asked by bokeefe on Oct 9, 2017

So I'm trying to prop up a GeoForm.

I need it to be on our Internal server and available to Employees not citizens.

SO!

I have the following:

A feature layer of points. A webmap containing those points. An Application referencing the GeoForm hosted on our server (internal address so I can't share).

 

What I get is this...

I'm about to pull my hair out.

 

In default.js I have entered the APPID, WEBMAP, FORM_LAYER and FIELDS as well as our internal Proxy and SHARINGHOST.

 

Now if I sign in with my ESRI account then it works. I haven't submitted a new address to test, but it loads and shows the fields I setup and everything. It LOOKS like I expect it to look. BUT... I don't want users to have to sign in. The very nature of where I put the GeoForm (internal server) means only internal users can access it. But if I SHARE the AGOL objects with the public then theoretically I could end up with outside users creating points. I do not want that.

 

I'm thinking that maybe I configured the proxy incorrectly?

 

<serverUrl url="https://developers.arcgis.com/applications/AppID"
username="myusername" password="mypassword" matchAll="true"/>
<serverUrl url="http://cityoftulsa.maps.arcgis.com/home/item.html?id=FeatureLayerID"
username="myusername" password="mypassword" matchAll="true"/>
<serverUrl url="https://cityoftulsa.maps.arcgis.com/home/item.html?id=AGOLWebMapID"
username="myusername" password="mypassword" matchAll="true"/>
<serverUrl url="http://internaladdress/geoforms/GeoFormName/"
username="myusername" password="mypassword" matchAll="true"/>
<serverUrl url="http://cityoftulsa.maps.arcgis.com/home/item.html?id=DeveloperAppID"
username="myusername" password="mypassword" matchAll="true"/>

 

I tried the ClientID and ClientSecret but that didn't work... so I switched to this option and still doesn't work.

Outcomes