AnsweredAssumed Answered

Unable to create new feature. Error: The table extension does not support the IAnnoClass Interface

Question asked by asrujit_pb Champion on Oct 8, 2017

One of our Utility clients has just upgraded everything from 9.2 to 10.2.1 (9.2 => 10 => 10.2.1 UTUP7). They use Ericsson Network Engineer(ENE), which was also upgraded from 5.x to 7.2.1, as that is supposed to be supported for ArcGIS 10.2.1. The underlying Oracle database was also upgraded from 10.2.0.3 to 11.2.0.4 in the process. All this is being done on new servers. 

 

The enterprise geodatabase upgrade and the ENE schema upgrade were completed successfully. However, now they are unable to edit existing data or create new features. The below error is received while trying to create a new feature:

 

               

The error mentions IAnnoClass Interface, which I am not familiar with and seems to be SDK related. This is what I found from a quick search:
IAnnoClass Interface 
http://help.arcgis.com/EN/sdk/10.0/Java_AO_ADF/api/arcobjects/com/esri/arcgis/carto/IAnnoClass.html

 

If anyone has seen this error or can help me in understanding what this error could indicate, that would surely help. I do plan on checking this with Esri Tech Support, if I don't get any suggestions here. Let me know if I can provide any more details which may help.

 

This was setup quite some time back, and never documented properly, so even the client is not able to provide any initial configuration details.

 

Managing Data Geodatabase ArcObjects SDK ArcObjects.NETEsri Technical Support

Outcomes