AnsweredAssumed Answered

Web Map issue

Question asked by reid.webb on Sep 15, 2017
Latest reply on Sep 21, 2017 by jhead@lakeworth

Hi! I have a web map issue that I cannot figure out. I have a MXD that I have published as a single feature mapping service that contains 10 or so different SDE layers. This feature mapping service is used in a web map. Everything was working great until I tried re-ordering some of the layers in the feature mapping service. The feature mapping service itself updated correctly. My issue is that now my web map that uses this feature mapping service is not picking up this change and now the web map queries the wrong attribute table when you click/query a feature in the web map. 

 

How can I fix the web map's internal pointers to the layers in the feature mapping service? Simply dragging them up and down in the web map doesn't fix the attribute table problem. I don't want to delete and recreate the web map because I will lose all the custom filters, popups, visibility scales, etc. that I have built into the web map.

 

I tried deleting and recreating the feature mapping service- didn't help.

 

Thank you in advance for your help!

Outcomes