AnsweredAssumed Answered

Sync fails at 10.5.1 with 500 error

Question asked by fsheagle-co-nz-esridist Employee on Sep 3, 2017
Latest reply on Sep 27, 2018 by jay.kapalczynski

Hi,

 

We have just upgraded a customer today to 10.5.1 from 10.4.1 and we have found that syncing with Collector now fails. The edits get pushed up to the enterprise geodatabase but do not come down from ArcGIS Server from the enterprise geodatabase.

 

After investigating it appears that during the sync process the GP tool is looking for the wrong schema in SQL Server for some of the temporary tables that get created.

 

  • We have SDE schema with geodatabase repository
  • We have GISADMIN schema with feature classes
  • ArcGIS Server runs as Domain\server_ArcGIS (OSA authentication)
  • Feature classes have archiving enabled

 

If we go offline with Collector the replica creation works fine, and if we sync, the edits get pushed up from Collector but it does not refresh the data from the enterprise geodatabase to the mobile device – we get a 500 sync failed error.

 

NOTE: The feature class is GIS.GISADMIN.SomePoints – syncing fails – ArcGIS Server has correct editing permissions assigned

 

If we give the ArcGIS Server creation rights on the enterprise geodatabase and create the feature class to be GIS.” Domain\server_ArcGIS”.SomePoints then all works as expected. If we set ArcGIS Server to connect to the enterprise geodatabase as the data schema owner (as a db connection GISADMIN) all works as expected.

This workflow was fine 10.1 through 10.4.1 – this customer has been using it.

 

 

Please note that versioned feature classes work as expected. It is just an issue with archiving.

 

 

Also be aware we have applied the recent SQL Server Permissions patch (10.5.1)

Has anyone hit this? This seems like a bit of a biggie.

 

Many thanks,

Fraser

Outcomes