AnsweredAssumed Answered

Active X,  issues with "Add Geometry" too;

Question asked by BrianKnel on Aug 15, 2017
Latest reply on Aug 31, 2017 by BrianKnel

I have been using the Add Geometry ARCGIS tool to add geometric data to records in a shape file of small of polylines. These small equal length polylines are the consequence of splitting a larger polyline. The Fluvial Corridor Centre line tool produces this larger polyline.

 

I have just upgraded my system to ARCGIS 10.5.1 and Win 10 on a Mac and for all intents and purposes appears to be performing as required with the exception that Add Geometry does not work. The tool stops with the errors shown when using shape files of polylines produced derived from this upgrade.

 

My previous system Win 7 + ARC 10.3+Mac worked reasonably well with the Add Geometry tool but became more likely to fail in a similar manner just prior to upgrade. I attributed this to lack of storage (the reason for upgrade)

 

With shape files from the previous system build I have set all geometric data derived by ADD Geometry to zero by using the field calculator in each table column. Those shape files which worked before still work with Add Geometry and those shape files that did not work with Add Geometry still fail to do so.

 

Both shape files are in the Map default gdb and these are attached labled work_shapefile and not_working_shapefile. The working_shapefile fields containing geometrical information have been set to zero.

 

The main difference between the two is the working shapefile/feature has an FID but the shapefile / feature that fails has an OBJECTID. I have tried to change the OBJECTID to FID using feature copy, there is no change. However as I understand it this difference should not matter.

Outcomes